Automatic Commission Generation Not Working!

Help and Community Tech Support for JROX eCommerce Manager
Post Reply
thecashg
Posts: 19
Joined: Fri Dec 05, 2014 7:04 pm

Automatic Commission Generation Not Working!

Post by thecashg » Sun Sep 27, 2015 7:25 pm

I have a local payment gateway - Interswitch WebPAY installed on my JEM site and am having problem automatically generating commissions to my affiliates. I tried using the Php code and later on, the following image script on my thank you page, all to no avail. I have changed the AMOUNT and Trans-ID variables appropriately and have also inserted my domain name as applicable. I viewed the source of the Thank you page and can see the inserted code there.

<img src="http://www.yourdomain.com/affiliates/sa ... d/$ORDERID" border="1" height="1" width="1" />

What could be impeding automatic generation of commissions please?

User avatar
forumadmin
Site Admin
Posts: 408
Joined: Fri Nov 07, 2014 4:50 pm

Re: Automatic Commission Generation Not Working!

Post by forumadmin » Fri Oct 30, 2015 9:02 pm

hello,

JEM already has its own affiliate marketing module. you don't need to integrate it with JAM as commissions will get generated in JEM when payment is made on an invoice.

thecashg
Posts: 19
Joined: Fri Dec 05, 2014 7:04 pm

Re: Automatic Commission Generation Not Working!

Post by thecashg » Thu Nov 05, 2015 12:44 am

What could be the possible reason then why commission is not automatically generated in JEM when invoice payment is made through the online payment gateway portal, despite commission generation being enabled in product options settings?

Thank you.

User avatar
forumadmin
Site Admin
Posts: 408
Joined: Fri Nov 07, 2014 4:50 pm

Re: Automatic Commission Generation Not Working!

Post by forumadmin » Thu Nov 05, 2015 1:14 am

first off, is the invoice payment being marked as paid?

did you click on an affiliate link when making the transaction?

if you view the invoice, is there a sponsor assigned for that invoice in the invoice details?

thecashg
Posts: 19
Joined: Fri Dec 05, 2014 7:04 pm

Re: Automatic Commission Generation Not Working!

Post by thecashg » Sat Nov 07, 2015 8:31 pm

forumadmin wrote:first off, is the invoice payment being marked as paid?
Yes, the invoice payment is being marked as paid.

forumadmin wrote:if you view the invoice, is there a sponsor assigned for that invoice in the invoice details?
Yes, there is a sponsor assigned for that invoice and is stated on the invoice within "view invoice"
forumadmin wrote:did you click on an affiliate link when making the transaction?
No, i did not click on an affiliate link when making the transaction. Rather, both the sponsor and the sponsored are members of the same affiliate program (enable affiliate marketing) and affiliate group and are enabled as such, with the affiliate group commission rate entered against the particular product the sponsored bought.

Thank you

thecashg
Posts: 19
Joined: Fri Dec 05, 2014 7:04 pm

Re: Automatic Commission Generation Not Working!

Post by thecashg » Mon Nov 09, 2015 9:27 am

I even tried the approach of the sponsored buying product through his sponsor's product affiliate link and commission was not generated either, despite the invoice being marked "paid" on payment and the sponsor's username appearing on the invoice.

User avatar
forumadmin
Site Admin
Posts: 408
Joined: Fri Nov 07, 2014 4:50 pm

Re: Automatic Commission Generation Not Working!

Post by forumadmin » Sun Dec 27, 2015 8:44 pm

are you clicking on the affiliate link and purchasing as the same affiliate?

if you are trying to purchase as the affiliate, you may have restrict self commissions enabled, so that users who try to purchase from their own affiliate link is not allowed.

you can change that in the settings > global configuration area.

Post Reply